Author Topic: 1.2.3.x  (Read 53420 times)

Revan

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: 1.2.3.x
« Reply #125 on: April 09, 2012, 03:10:49 AM »
Seems like you missed installing war3dll.ext, Check your extension folder
#war3source on gamesurge

Wangwang

  • Newbie
  • *
  • Posts: 20
    • View Profile
    • Email
Re: 1.2.3.x
« Reply #126 on: April 09, 2012, 04:30:41 AM »
Seems like you missed installing war3dll.ext, Check your extension folder
It's not in there but I can't seem to find it anywhere, either on the download page or SVN T_T

Revan

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: 1.2.3.x
« Reply #127 on: April 09, 2012, 06:30:40 AM »
its in the war3source download
addons/extensions/war3dll.ext.dll (for windows) or war3dll.ext.so (for linux)
#war3source on gamesurge

Wangwang

  • Newbie
  • *
  • Posts: 20
    • View Profile
    • Email
Re: 1.2.3.x
« Reply #128 on: April 09, 2012, 03:17:55 PM »
Re-downloaded it, still don't see it in the release anywhere. Not a clue what's going on :/

There are war3dll.dll and war3dll.so both of which are in the extensions folder already if that's what you mean however.

Scyther

  • Full Member
  • ***
  • Posts: 121
    • View Profile
    • Email
Re: 1.2.3.x
« Reply #129 on: July 19, 2012, 04:18:00 AM »
Having an odd issue with war3 at the moment using the newest packaged version (nothing custom) im getting to:

Failed to load steam Service
ServiceStart: failed to start

and it suddenly stops there..

I know it is an issue with war3 as with just SM/SDK/MM it works fine, the moment i add in war3 even a clean install of it i get to this stage and it stops..

Any ideas?

Ownz

  • Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 2437
  • chmod -R 777 *
    • View Profile
    • OwnageClan
Re: 1.2.3.x
« Reply #130 on: July 19, 2012, 08:44:34 PM »
update sm

Scyther

  • Full Member
  • ***
  • Posts: 121
    • View Profile
    • Email
Re: 1.2.3.x
« Reply #131 on: July 20, 2012, 01:56:28 AM »
Yeah thanks :D

Piiing!!!

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: 1.2.3.x
« Reply #132 on: July 23, 2012, 10:02:28 AM »
Download broken.

Get this error when opening the .rar.

"D:\css\Downloads\War3Source\War3SourceP1.2.3.6.rar: Unexpected end of archive"

I've tried re-downloading several times with the same result.

Ownz

  • Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 2437
  • chmod -R 777 *
    • View Profile
    • OwnageClan
Re: 1.2.3.x
« Reply #133 on: July 27, 2012, 10:49:26 AM »
use a different browser, restart your computer, clear your cache

Ownz

  • Developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 2437
  • chmod -R 777 *
    • View Profile
    • OwnageClan
Re: 1.2.3.x
« Reply #134 on: September 21, 2012, 09:00:42 PM »
or just
if(GAMECS)

#define GAMECS GameCS()
#define GAMETF GameTF()
#define GAMEL4D1 GameL4D1()
#define GAMEL4D2 GameL4D2()
#define GAMEL4DAny GameL4DAny()
#define GAMECSGO GameCSGO()
#define GAMECSANY GameCSANY()

Revan

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: 1.2.3.x
« Reply #135 on: September 23, 2012, 04:00:56 AM »
Major fix!  1.2.3.9

We are almost completely stable (Not sure when they will release CS:GO) but I'm trying to keep at least TF2 running stable while they make the updates to CS:GO.

As far as I can tell, TF2 loads much faster now since this update.

Updated War3Source_Engine_MenuChangerace.sp to svn.

We've been hunting down for this stack overflow for awhile, wonder why you can't increase stack size enough??

The problem is we are refreshing the Categories too fast causing the stack to overflow!  At least it's my theory.

I added a delay to the refreshCategories() in the OnMapStart() section of War3Source_Engine_MenuChangerace.sp

After adding a 5 second delay, I was able to load everything in the svn folder, including the SH stuff without any stack error!

I only get 1 bug: 09/23/2012 - 02:31:55: [war3source/War3Source_Addon_ClanBonusXP.smx] InitNativesForwards did not return true, possible failure

I'm going to try to figure out if any of the code is good for TF2, and separate it out if I can.


P.S.  Even though there is a 5 second delay, some of you may notice your server loads faster :P


Oh thats nice!
That ClanBonusXP error is entirely my fault and was fixed in the main repository some revisions ago by just adding "return true;" to InitNativeForwards.
#war3source on gamesurge