Author Topic: [Help] I am having trouble compiling WCS Evo  (Read 327 times)

Runda

  • Newbie
  • *
  • Posts: 1
    • View Profile
[Help] I am having trouble compiling WCS Evo
« on: December 10, 2016, 09:40:40 PM »
I have re-done the installation many times now, I have followed the wiki, I have tried random solution people have from alliedmodders, but I still cannot get past this issue.

Code: [Select]
//// War3Source.sp
//
// War3Source/War3Source_Engine_SteamTools.sp(68) : error 017: undefined symbol "bIsInSteamGroup"
// War3Source/War3Source_Engine_SteamTools.sp(68) : warning 215: expression has no effect
// War3Source/War3Source_Engine_SteamTools.sp(68) : error 001: expected token: ";", but found "]"
// War3Source/War3Source_Engine_SteamTools.sp(68) : error 029: invalid expression, assumed zero
// War3Source/War3Source_Engine_SteamTools.sp(68) : fatal error 190: too many error messages on one line
//
// Compilation aborted.
// 4 Errors.

That is my error I get when I try to compile, I DID change the include file EVERYTIME I try, I make sure it is correct.

I am trying to get this working on CS:S and been working at for 2 days almost now, any help would be appreciated.

Edit: So I went looking for what line was wrong, and it was "bIsInSteamGroup" That "new bool" is commented out on the master branch, so I dunno if I missed something but I had to uncomment that and it all is working now.
« Last Edit: December 11, 2016, 01:09:58 AM by Runda »

Revan

  • Hero Member
  • *****
  • Posts: 513
    • View Profile
Re: [Help] I am having trouble compiling WCS Evo
« Reply #1 on: December 11, 2016, 05:31:24 AM »
War3Source_Engine_SteamTools is not a stock war3source plugin.
Where did you get it? probably a version by El Diablo given how War3Source.sp includes War3Source_Engine_SteamTools.sp
#war3source on gamesurge

El Diablo

  • Hero Member
  • *****
  • Posts: 1126
    • View Profile
    • War3Evo
Re: [Help] I am having trouble compiling WCS Evo
« Reply #2 on: December 16, 2016, 12:16:35 PM »
The same post is on the Sourcemod forums. https://forums.alliedmods.net/showpost.php?p=2476621&postcount=61

If you don't want to wait for me to update that, then grab a copy from this website.  I'm sure the CSS version works here, unless your looking for specific improvements from my version?

In truth, nobody ever bothered me to get a CSS version working... Plus it once worked for CSS in the past, so I was guessing a good programmer could make it work again on thier own time or grab a copy from here.
« Last Edit: December 16, 2016, 12:20:39 PM by El Diablo »